Gelöst

Netzinternes Routingproblem o2-CGN/public -> o2-public-IP


Benutzerebene 3

Hallo liebe Community,

leider gibt es seit mindestens einem halben Jahr ein bestätigtes Routingproblem bei Verbindungen von o2(Mobilfunk) [egal ob über den "internet”-CGN-Accesspoint oder über den funktionierend freigeschalteten "netpublic”-Accesspoint] ZU einer öffentlichen o2-IP aus dem 89.204.131.*-Block.

Netzexterne Verbindungen von anderen Anbietern ausgehend, werden problemlos bis zur zugewiesenen öffentlichen 89.204.131*er-IP durchgreoutet – innerhalb des Netzes ist jedoch keine Verbindung auf die betreffende IP möglich.

Das Problem hatte ich erstmals im Spätsommer letzten Jahres bei den Hotline-Gurus erläutert. Anscheinend existiert in dieser Sache auch ein"Masterticket". Nur weiß irgendwie niemand, ob/wann hier nochmal was passiert.
 

Wäre toll, wenn ich kurz konkreten Input über das weitere Vorgehen/Timing in dieser Angelegenheit bekommen könnte.

icon

Lösung von o2_Matze 19 März 2020, 09:58

Wow, danke @ThomasA_FFM und @ausdemdorf für eure Vorarbeit und das massive testen.

Ich hab die Infos noch mal weiter gegeben. 

VG Matze 

 

Zur Antwort springen

303 Antworten

Benutzerebene 3

@o2-Moderatorenteam: Könntet Ihr bitte bei den zuständigen Kollegen nachhaken? Das wäre lieb! Vielen Dank im Voraus.

Benutzerebene 4

Ich schließe mich an,

das Problem nervt, wurde laut Hotline schon im Dezember an die Technik weitergeleitet (seitdem habe ich den Tarif). Taucht hier im Forum auch immer mal wieder auf.

 

Bitte an die Technik zur Behebung weiterleiten!

Benutzerebene 7

Hallo zusammen. 

@ausdemdorf  und @ThomasA_FFM Bitte sendet eine private Nachricht mit euren Daten (Rufnummer und persönliche Kundenkennzahl zur Legitimation, falls ihr diese nicht kennt bitte Name, Geb.Datum und die letzten vier Ziffern eurer IBAN)  an unseren o2 Support User , danach hier bitte wieder kurz Bescheid geben,  dann verschaffen wir uns einen Überblick.

VG Matze   

 

Benutzerebene 3

Hallo Matze,

habe die Daten an den Support-User gesendet. Vielen Dank schonmal für Deine Hilfe! :)

 

Grüße

Thomas

Benutzerebene 3

Nochmal ein Nachtrag zur Verdeutlichung:

 

Von o2-netpublic-AP ( 89.204.131.*** ) -> o2-netpublic-IP ( 89.204.131.*** ): 

[Öffentliche o2-IP innerhalb des mobilen Datennetzes von o2 nicht erreichbar. Egal von welchem Ort in DE, egal mit welchem Verbindungsprotokoll, egal mit welchem Device]

———————————

Von o2-internet-AP ( 46.114.0.149) -> o2-netpublic-IP ( 89.204.131.*** ):

[Hier das gleiche Szenario. Keine Verbindung.]

 

———————————

Von Telekom-DSL ( 93.212.**.** ) -> o2-netpublic-IP ( 89.204.131.*** ):

[Verbindung erfolgreich. Routing erfolgt problemlos durch das ganze o2-Netzwerk bis zum mobilen Endgerät mit der Public-IP]

 

traceroute to 89.204.131.*** (89.204.131.***) , 5 relative hops max, 52 byte packets

 

   1 fritz.box (192.168.178.1) 3.771 ms 17.741 ms 18.650 ms

   2 62.155.246.** (62.155.246.**) 14.114 ms 15.902 ms 16.769 ms

   3 f-*****.f.de.net.dtag.de (62.156.131.***) 13.307 ms 24.882 ms 26.903 ms

   4 80.157.131.182 (80.157.131.182) 13.535 ms 14.950 ms 15.695 ms

   5 176.52.252.29 (176.52.252.29) 19.507 ms 1028.134 ms 1031.164 ms

   6 62.53.8.186 (62.53.8.186) 22.489 ms 40.577 ms 42.964 ms

   7 62.53.0.126 (62.53.0.126) 25.038 ms 44.847 ms 47.182 ms

   8 62.53.5.82 (62.53.5.82) 33.149 ms 48.017 ms 52.194 ms

   9 62.53.5.67 (62.53.5.67) 41.545 ms 60.129 ms 63.380 ms

 10 62.53.0.111 (62.53.0.111) 35.475 ms 55.493 ms 60.297 ms

 11 62.52.30.78 (62.52.30.78) 33.173 ms 79.471 ms 82.315 ms

 12 82.113.122.9 (82.113.122.9) 23.586 ms 27.260 ms 29.911 ms

 13 82.113.122.194 (82.113.122.194) 24.832 ms 27.898 ms 29.637 ms

 14  * * *

 15 89.204.131.*** (89.204.131.***) 64.466 ms 68.103 ms 71.225 ms

Benutzerebene 4

*meld* Wie gewünscht habe ich soeben dem Supportaccount geschrieben.

 

Ich habe aktuell leider keine ausführlicheren Daten zur Hand aber, ThomasA_FFM trifft es.

Benutze ich mein Privathandy mit o2 Vertrag, kann ich keinerlei Verbindung aus dem o2 Netz zu der gebuchten dynamischen IPv4 des Homespot aufbauen, realisiert über DDNS (no-ip.com).

Benutze ich eine andere SIM mit Netz der DTAG ist dies kein Problem.

Benutzerebene 7

Hi @ThomasA_FFM  und @ausdemdorf  

Vielen Dank für die Infos und die private Nachricht. Wir haben das intern an die Fachabteilung weitergeleitet. 

Fürs erste kann euch da jetzt nur um Geduld bitten. 

Eine Frage noch: Was passiert genau wenn es ihr versucht via o2 Vertrag auf die IPv4 z.B des Homespots zuzugereifen? Gibt es irgend eine Art von Fehlermeldung?

@ thomas Beim tracetoute via o2 SIM passiert gar nichts? 

Habt ihr das von verschiedenen o2 Verträgen / Nummer ausprobiert?

Gruß Matze 

 

Benutzerebene 4

Vom o2 Vertragshandy 10.169.191.xxx aus auf die public IP des LTE Routers 89.204.147.xxx rennt sich ein Traceroute tot. *Zeitüberschreitung der Anforderung*.
Vom LTE Router in Richtung Handy rennt sich der Traceroute ebenfalls tot.

Vom DTAG Anschluss (87.149.186.xxx) in Richtung LTE Router läuft der Traceroute über maximal 30 Hops:


Routenverfolgung zu edited.edited.edited [89.204.147.xxx]
über maximal 30 Hops:

  1    <1 ms    <1 ms    <1 ms  192.168.1.1
  2    73 ms    64 ms    54 ms  62.155.244.104
  3    20 ms    67 ms    74 ms  217.5.110.162
  4    35 ms    50 ms    20 ms  80.156.161.74
  5    76 ms    80 ms    84 ms  213.140.51.61
  6    32 ms    19 ms    20 ms  ae3-0.0001.dbrx.02.dus.de.net.telefonica.de [62.53.1.35]
  7    67 ms    64 ms    32 ms  ae1-0.0001.corx.02.dus.de.net.telefonica.de [62.53.0.26]
  8    26 ms    78 ms    52 ms  ae5-0.0002.corx.02.fra.de.net.telefonica.de [62.53.0.20]
  9    42 ms    61 ms    25 ms  bundle-ether6.0002.dbrx.02.fra.de.net.telefonica.de [62.53.0.143]
 10    64 ms    63 ms    63 ms  ae4-0.20.xmws.99.fra.de.net.telefonica.de [62.53.2.51]
 11    53 ms    32 ms    73 ms  as0-0.02.rmwc.99.gut.de.net.telefonica.de [62.53.2.55]
 12    77 ms    87 ms    79 ms  82.113.103.39
 13    23 ms    23 ms    25 ms  82.113.103.66
 14     *        *        *     Zeitüberschreitung der Anforderung.
 ...
 30     *        *        *     Zeitüberschreitung der Anforderung.

Ablaufverfolgung beendet.

 

VPN Verbindung von DTAG Anschluss zu LTE o2 klappt.

VPN Verbindung von LTE o2 an DTAG Anschluss klappt.

VPN Verbindung von o2 Handy an LTE o2 nicht möglich.

VPN Verbindung von o2 Handy an DTAG Anschluss klappt.

Benutzerebene 3

Guten Abend @o2_Matze,

lieben Dank für die Rückmeldung.

Also… Irgendwas müssen Du oder die Fachabteilung in den letzten drei Stunden rumgefummelt haben – denn: Zumindest funktionierte jetzt mehrmals (aber noch nicht ganz zuverlässig) ein weiter Setup:

 

——————

Siehe Bild 1) Setup: Device 1 mit o2-"internet"-AP-IP  =>> Device 2 mit “netpublic”-IP:
 

Verbindung ging nun in den letzten zwei Stunden sehr häufig erfolgreich durch [aber nicht immer, nach ner halben Std. nochmal probiert - da gings dann nichtmehr, jetzt geht es wieder]. Getestet wurde mit VPN-Tunnelaufbau und eben Traceroute.

In den letzten 6 Monaten hat das zuvor NIE funktioniert. Also irgendwas habt ihr da scheinbar bei euch nun rumgewerkelt, was in die richtige Richtung ging :-) :-)

——————

 

ABER...

Siehe Bild 2) Setup: Device 1 im den Einstellungen abgeändert auf “netpublic”-IP =>> “netpublic”-IP:

Verbindung geht unverändert noch immer nicht:

 

 

 

Ihr seid auf dem richtigen Weg… Ich gebe morgen nochmal Rückmeldung, ob sich über die Nacht etwas getan hat.

 

Lieben Dank schonmal!

Benutzerebene 3

Kurz als Memo: Nun kommt seit 30 Minuten keine Verbindung mehr zustande (weder bei Einwahl über “internet” noch über “netpublic”).

Die o2-public-IP der Gegenstelle hat sich zwischenzeitlich nicht geändert, Gegenstelle ist definitiv online und jetzt in diesem Moment über das Telekom-Netz problemlos ruckzuck erreichbar. Also: Same issue as before.

 

Aber: Zumindest gab es an diesem Abend mal 4 erfolgreiche Verbindungen, die davor NIE zustande kamen.

 

Es bleibt spannend. Wenn Du oder die Fachabteilung weitere Infos braucht – gerne :)

 

Zu deiner Frage noch: Ich selbst hab nur diesen einen Vertrag bei o2 (mit Connect-Funktion, bei der die SIM-Karten für die netpublic haben wollte auch aktiviert wurden). Daher kann ich jetzt nicht testen, ob die Sache userbezogen ist…. Aber hier in der Community haben schon mehrere User von diesem Problem berichtet. Vermutlich nutzen die meisten Leute ihre beantragte öffentliche IP eher "nur” für Gaming-Sachen (da fällt das ja nicht auf) und halt verhältnismäßig wenige für o2-Netzinterne SIMtoSIM-VPN-Tunnel o.ä. von denen sich dann auch wieder nur 5% hartnäckig dahinterklemmen, wenn es nicht geht.

Benutzerebene 7

Hi @ThomasA_FFM  und @ausdemdorf 

Danke für die Beispiele und Screenshots. Wir leiten dass an die Kollegen weiter. Sobald es dazu ein Update gibt melden wir uns wieder hier. 

Gruß Matze 

Benutzerebene 3

Hi zusammen,

kurzer Zwischenstand von meiner Seite: Die o2-internen Verbindungen funktionieren leider unverändert nicht

Das Problem dürfte jedoch jeder Techniker ohne Probleme reproduzieren können wenn er versucht, sich mit seinem im o2-Netz eingebuchten Handy bspw. auf die aktuell zugewiesene IP meiner SIM mit derEndziffer ***6459 zu pingen oder tracerouten [Leitung tot] – und dann vergleichsweise nochmal einen Online-Traceroute-Dienst nutzt, der nicht aus dem o2-Netz startet [hier funktioniert es].

Das Ticket mit der Nr. CDY000000673438 erhält eine Meldung vom 08.10.2019, die dieses Problem erstmalig beschreibt. Leider wurde es – wie ich eben erfahren habe – am 27.01.20 kommentarlos ohne Lösung im System geschlossen.

 

Hoffentlich verfahren die Kollegen aus der Fachabteilung jetzt anders :-)

 

 

 

Hier eine Auswahl an weiteren Usern aus der Community, die im Grundsatz das gleiche Problembild beschreiben:

 

„Der Zugriff auf den Server (bei Chemnitz) über die O2-Karte mit der öffentlichen IP über die O2-Karte mit der privaten IP hat von einem Standort bei Leipzig aus voriges Jahr noch ganz gut funktioniert, aber jetzt leider nicht mehr. Vom zweiten Standort bei Berlin aus hat es nie funktioniert. Clientseitig verbinde ich mich mit meinem Handy und USB-Thetering über meine O2-Karte und dem AP “internet”, [die] zweite O2-Karte [ist] mit dem AP “netpublic” und einem USB-Stick verbunden. Ich denke mal, es hängt am internen Routing im O2-Netz in Kombination mit interner und externer IP“ -> https://hilfe.o2online.de/mobilfunk-vertrag-tarife-15/probleme-mit-externer-ip-514203#post2007632

 

————————————————

 

„ich nutze den Homespot Unlimited Vertrag und habe mir eine öffentliche IP Adresse geholt. [...] Der Zugriff über die NAS funktioniert ohne Probleme wenn ich aus einem anderen Netzwerk / Anbieter aufrufe. [...]  Sobald ich versuche mit dem Handy über meine SIM (O2 LTE Netz) darauf zuzugreifen kann er die NAS nicht mehr erreichen / routen. Andere Zugriffe ins Internet funktionieren ohne Probleme.“ ->

https://hilfe.o2online.de/mobiles-internet-lte-homespot-21/o2-homespot-mit-public-ip-adresse-nas-nicht-aus-o2-netz-erreichbar-518761

 

————————————————

 

„ich habe das Problem, dass ich aus dem o2-Netz heraus nicht auf meine LTE-Fritzbox per https zugreifen kann. Die Box hat von o2 eine öffentliche IP und ist über den APN netpublic eingeloggt. [...] Wenn ich im Handy jedoch eine Telekom-SIM benutze, klappt der Zugriff.“ Hier hat man sich dann leider auf die https-Verbindung als mögliche Ursache versteift ->

 https://hilfe.o2online.de/sim-karte-multicard-datenkarten-17/https-zugriff-auf-lte-router-511777

 

————————————————

„Dennoch bleibt es dabei, das ich aus dem Mobilfunknetz nicht durch komme, aus anderen Wlans schon. [...] Finde es etwas merkwürdig, dass es scheinbar normal läuft, aber eben Mobilfunknetz gesperrt ist.“ [....]

„[...] kann ich nicht mit meinem Handy aus dem O2 Netz auf die externe IP Adresse meines Homespot zugreifen, solche Berichte finden sich auch einige Male hier im Forum.

Leider weiß die Hotline keinen Rat oder hat davon noch nie gehört, das hinterlässt einen bitteren Beigeschmack wenn man bedenkt das diese Fehler hier schon seit kurz nach Einführung des Produkts gemeldet wurden.“ ->

https://hilfe.o2online.de/mobiles-internet-lte-homespot-21/heute-vpn-verbindung-nur-aus-wlan-netz-moeglich-homespot-unlimited-521204#post2014243

Benutzerebene 7

Hallo @ThomasA_FFM 

Danke für die Beispiele. Die Fachabteilung ist noch dran, ein Update liegt noch nicht vor, sobald ich aber neue Infos habe melde ich mich wieder hier. 

VG Matze 

Hallo Zusammen,

ich muss mich dieser Runde jetzt auch anschließen.

Bei mir äußert sich das Problem so, dass ich mit meinem Smartphone aus dem O2 Netz heraus nicht auf meinen Server am O2 Homespot zugreifen kann. 

Wenn ich mit dem selben Gerät aus einem anderen WLAN heraus zugreife, dann funktioniert alles problemlos. Im Unterschied zu euch läuft mein Mobilfunkvertrag aber über einen Reseller.

Was mich allerdings wundert: Der Zugriff lief jetzt mehrere Monate ohne Probleme. Erst seit einem Homespot Neustart letzte Woche klappt der Zugriff nicht mehr. 

Ich kann leider nicht mehr nachvollziehen, ob ich seit dem Neustart in einem anderen IP-Adress-Bereich gelandet bin. Möglicherweise betrifft es nicht alle Bereich mit öffentlicher IP? Ich habe versucht durch weitere Neustarts in einem anderen Bereich zu kommen, lande aber immer wieder in 89.204.xx.0/24. Und immer ohne Zugriff auf den Server ;(

LG

 

Benutzerebene 7

Hi @troelf 

Aktuell kann ich nur um Geduld bitten. Bisher haben wir noch keine weiteren Infos bekommen.

Die Einschränkungen sind an ein MasterTicket angefügt worden, die Technik untersucht das ganze aktuell,

bisher liegt uns aber noch kein Update vor.

VG Matze 

Benutzerebene 1

Hallo,

Muss mich nun auch mal zu euch gesellen :)

Vielleicht gibt es ja bald eine Lösung.

über die Hotline “guro” heist es übrigens gibt keine Probleme bis ich dann hier gelandet bin.

 

 

 

 

Benutzerebene 3

Hallo @Darky11111  :)

Wie äußert sich das Problem bei Dir konkret?

 

Gruß

Thomas

Benutzerebene 1

Hallo @Darky11111  :)

Wie äußert sich das Problem bei Dir konkret?

 

Gruß

Thomas

Habe sonst immer div home Server betrieben sei es nas oder Status abfragen per handy (um mal schnell was auf arbeit zu starten oder jobs anzustoßen) und und und…

Öffentliche ip Gebucht gut alles mal bisl umgestaltet und Abend der ganzen Hardware gerichtet.

Div traces laufen einfach im timeout (kommen bei meiner ip einfach nicht an). (nicht erreichbar) Vom smartphone nie erreichbar (o2) 

 

Da ich erst dachte machst irgend ein Fehler….….. andere lte Hardware probiert (o2 spot weg was von Huawei,Fritzbox dran) mit den gleichen Ergebnis nicht erreichbar oder habe ich einfach Denkfehler ?

 

Öffentliche ip Ist in der box sichtbar der nat hat sich auf div konsolen geändert Mehr geht jedoch nicht.

 

 

 

Benutzerebene 3

Hallo @Darky11111  :)

Wie äußert sich das Problem bei Dir konkret?

 

Gruß

Thomas

Habe sonst immer div home Server betrieben sei es nas oder Status abfragen per handy (um mal schnell was auf arbeit zu starten oder jobs anzustoßen) und und und…

Öffentliche ip Gebucht gut alles mal bisl umgestaltet und Abend der ganzen Hardware gerichtet.

Div traces laufen einfach im timeout (kommen bei meiner ip einfach nicht an). (nicht erreichbar) Vom smartphone nie erreichbar (o2) 

 

Da ich erst dachte machst irgend ein Fehler….….. andere lte Hardware probiert (o2 spot weg was von Huawei,Fritzbox dran) mit den gleichen Ergebnis nicht erreichbar oder habe ich einfach Denkfehler ?

 

Öffentliche ip Ist in der box sichtbar der nat hat sich auf div konsolen geändert Mehr geht jedoch nicht.

 

 

 

Sind dein NAS oder Server (mit öffentlicher mobilen o2-IP) nur von einer o2-SIM aus nicht zu erreichen – oder funktioniert der Verbindungsaufbau auch über das Netz eines anderen Anbieters nicht?

@o2_Matze wie ist hier der aktuelle Stand?

Ich bin schon etwas überrascht wie lange es dauert eine Lösung zu liefern. Mit der detaillierten Beschreibung hier im Forum ist das Problem für einen Techniker sicher ganz einfach nachzustellen. 

Ich weiß nicht wie es meinen “Leidensgenossen” ergeht, aber für mich ist die Funktion sehr wichtig. 

Die schnellste Lösung für mich wäre es, einfach den Mobilfunkprovider zu wechseln. Nach Tests mit Telekom und Vodafone Geräten kann ich bestätigen, dass es dann funktioniert. Aber der Wechsel kann ja nicht im Interesse von O2 sein - also bitte tut was!

Benutzerebene 4

Mich würde hier der aktuelle Stand interessieren.

 

Was sagt die Technik dazu?

Bis wann kann mit einer Lösung gerechnet werden?

 

Benutzerebene 3

Dito. "MasterTickets” & Co. zu diesem Problembild gibt es schon seit mindestens 6 Monaten. Die nächste Option wäre dann, über Xing + LinkedIn sämtliche Netz/IT/Infrastruktur-sonstwas-Mitarbeiter von Telefonica anzuschreiben, die einem in die Finger kommen; in der Hoffnung, dass sich von denen jemand erbarmt. Das kann es aber ja eigentlich auch nicht sein.

Benutzerebene 7

Hallo zusammen.

Wir haben bei der Fachabteilung noch mal nach einem Update gefragt. 

Sobald uns dazu eine Antwort vorliegt melden wir uns wieder hier. 

VG Matze 

Dann will ich auch mal…

Ich hatte vorher eine LTE Flat mit öffentlicher Ip4 (Telekom APN) bei der Telekom. 

Habe vor kaum 2 Wochen auch diesen Vertrag (mittlerweile alle 3 bei O2) als Flat mit einer öffentlichen Ip4 gekündigt und bei O2 neu abgeschlossen und über die bekannte APN wurde mir dann auch eine öffentliche Ip4 zugeteilt.

Vorher konnte ich von Extern mit meinen O2 Geräten auf diverse Geräte in meinem Netzwerk zugreifen, jetzt ging es plötzlich nicht mehr obwohl ich nur den Anbieter gewechselt habe.

Ich habe also erstmal den Fehler bei mir gesucht, bis ich jetzt diesen Thread gefunden habe und meinen, naja den Fehler von O2 gefunden habe.

 

Ich hoffe das hier möglichst bald eine Lösung gefunden wird und möchte hiermit auch nur einen weiteren Kunden als betroffen melden, da es ja doch ein eher Spezielles Problem ist.

 

Grüße

Benutzerebene 7

Hallo @Bosper 

Willkommen in unserer Community und danke für deine Nachricht. 

Die Anfrage bei den Kollegen der Technik läuft noch, sobald wir Rückmeldung haben melden wir uns wieder hier.

VG Matze  

Deine Antwort