Warum O2
Warenkorb
Service
Gelöst

VPN/Tunnel via O2 DSL

  • 29 September 2010
  • 9 Antworten
  • 8055 Aufrufe

Hi zusammen,

 

ich hoffe, der ein oder andere Leser hier hat mit diesem Thema bei O2 schonmal Erfahrung gemacht, denn ich habe das Gefühl, dass man versucht, mir Kosten aufzudrücken, die eigentlich nicht erforderlich sind.

 

Also, ich benutze den DSL Router Premium, um mich mit dem Internet zu verbinden. Vor 2 Wochen wollte ich mich via VPN mit dem OpenVPN Client mit dem Server eines gemeinnützigen Vereins, in welchem ich Mitglied bin, verbinden - die Verbindungsdaten sind in Ordnung (über andere Anbieter/Router klappt die Verbindung), aber irgendwie scheine ich im Bezug auf die Router-Einstellungen nicht ganz auf dem Laufenden zu sein...

 

Ein Anruf bei der O2-Premiumkunden-Hotline (ich bin seit ca. 9 Jahren O2-Kundin und habe mittlerweile 2 Mobilfunkverträge und 1 Surf&Phone-Vertrag bei O2, wodurch der Monatsumsatz entsprechend hoch ist...) am vergangenen Dienstag schien eine Lösung in greifbare Nähe rücken zu lassen - zwar konnte man mir direkt nicht weiterhelfen, jedoch wurde mir versprochen, dass ich innerhalb von 24 Stunden zurückgerufen würde um mich bei den Einstellungen zu unterstützen. Dieser Rückruf erfolgte nicht.

 

Gestern habe ich nun die Hotline erneut angerufen, wo mir dann auf einmal mitgeteilt wurde, dass VPN überhaupt nicht unterstützt würde... es sei denn, ich zahle 83,00 € - dann würde man das freischalten. Auf Nachfrage, warum das so teuer sei, sagte man mir, dass ein Techniker kommen müsse, um irgendetwas am Telefonanschluss umzuschalten.

 

Nachdem ich heute noch einmal konkret zum Thema VPN/O2 DSL recherchiert habe, habe ich das Gefühl, dass man mir entweder aus Unwissenheit oder aus Profitgier nicht ganz die Wahrheit gesagt hat und dass eigentlich nur die Router-Einstellungen stimmen müssen, um die Verbindung herstellen zu können.

 

Stimmt es wirklich, dass für die Einrichtung eines Tunnels zu einem Server, der bereits entsprechend konfiguriert ist, ein Techniker irgendwelche Schalter für meinen DSL-Anschluss umlegen muss? Es handelt sich wohlgemerkt um einen Festnetzanschluss und nicht um eine UMTS-Verbindung!

 

Viele Grüße

odras

 

 

icon

Lösung von Pseudonym 29 September 2010, 14:57

Zur Antwort springen

Zu diesem Thema können keine neuen Antworten hinzugefügt werden. Du kannst gern ein eigenes Thema erstellen.

9 Antworten

Hallo,

 

also, o2 Unterstützt VPN von Haus aus, also direkt freigeschaltet werden muss es NICHT, eventuell gab es da ein Missverständnis an der Hotline. Ein Techniker kann (wenn die entsprechenden Kenntnisse vorhanden sind) sicherlich bei der Einrichtung behilflich sein.

VPN ist nicht gleich VPN, die o2 Technik kann hierzu höchstens ein paar kleine Hilfestellungen geben, aber ... wer VPN nutzt sollte wissen was er wie wo einstellen muss, denn diese Einstellungen sind in der Regel überall gleich, befinden sich nur von Router zu Router an unterschiedlichen Plätzen.

 

Ok, also Netzseitig unterstützt o2 alle Protokolle ausser GRE, den Hintergrund dazu kenne ich auch nicht. Ich habe FRITZ!VPN mit IPSEC laufen und ich habe keine Probleme, also es geht. Ist das verwendete Protokoll also GRE, dann geht es einfach nicht. Welches Protokoll verwendet wird ist glaibe ich im VPN Client ersichtlich.

 

Für ausgehende VPN Verbindungen ist im Regelfall auch gar keine Freischaltung von Ports nötig, nur wenn entsprechende eingehende Anfragen kommen, das könnte im Protokoll, wenn eingeschaltet, ersichtlich sein. Des Weiteren dürfen sich die beiden Netze nciht im gleichen IP Adressbereich befinden; wenn diesbezüglich keine Infos vorliegen einfach die IP des Routers auf 192.168.178.1 ändern (wäre beispielsweise die IP einer FRITZ!Box) *wenn es woanders geht, dann einfach die IP des Routers abfragen und entsprechen im Zyxel anpassen*.

 

Was noch? Dann kann man sowohl die NAT mit dem entsprechenden Port auf den Rechner weiterleiten und die Firewall konfigurieren. Rechner IP und Port vorher raussuchen, Rechner IP aus Betriebssystem auslesen und Port aus VPN-Client.

 

Mehr fällt mir aber so auch nicht ein, Hoffe das hilft weiter. VG

Hallo,

 

hier vollkommen korrekt beschrieben von User Christian, ich hoffe es klappt wie gewünscht!

 

dein o2_Jan

 

 

Vielen Dank für eure Antworten.

 

Ich habe das Problem mit Hilfe eines befreundeten Netzwerktechnikers lösen können. Was mich hier vor allem irritierte und auch ein wenig ärgerte, war/ist die Tatsache, dass ich von den CallCenter-Mitarbeiterinnen der Technik-Abteilung mit einer Information abgespeist wurde, die jeglicher Grundlage entbehrt. Mir ist ein ehrliches "Tut mir leid, in diesem Bereich kann ich Ihnen leider nicht weiterhelfen, ich kenne mich damit nicht aus!" lieber, als ein an den Haaren herbeigezogenes Argument...

 

Vielleicht sollte man das Premium-Beraterteam insbesondere der Technik-Abteilung dahingehend etwas besser schulen...

 

Viele Grüße

odras

 

Hi,

 

was war letztendlich die Lösung? Wäre auch für andere User sicherlich interessant, wenn diese solch einen Fehler haben.

 

Viele Grüße

In diesem konkreten Fall war das Problem, dass die VPN-Verbindung nicht wie allgemein üblich via IPsec hergestellt wird, sondern dass das Ganze über SSL läuft - ich hatte schlicht und ergreifend meinem VPN-Client falsch konfiguriert. Am Router/Anschluss lag es gar nicht...

 

Deine Antwort hat mir aber insofern geholfen, als dass ich damit sicher wusste, dass kein o2-Techniker benötigt, wird, der am Anschluss an sich irgendwelche Einstellungen vornehmen muss, die ein man als "einfacher" Kunde nicht vornehmen kann...

 

LG

odras

Vielen Dank @Christian, die Hilfestellung hat mir super geholfen, bei mir lag es am IP-Adressbereich.

 

VG

Ich hatte auch Problemen mit OpenVPN - nur über VDSL mit dem 6431 O2 Box (über ADSL mit dem Siemens Router war alles ok). Die Verbindung war zwar jedes mal erfolgreich, danach war die Verbindung so langsam dass surfen noch kaum möglich war. Das Problem ist das OpenVPN standardmäßig  über port 1194 mit UDP verbindet.

 

Stellt man auf TCP um in der OpenVPN Client-config, dann wirkt alles ohne Probleme. Nur ist TCP prinzipiell viel langsamer als UDP. (Siehe meine Messungen unter.) Der Trick hier ist um die MTU-Werte runterzuholen: füge in der Client-Config eine Zeile zu:

 

mssfix 1400

 

Und dann läuft OpenVPN auch mit UDP. 🙂 Schneller als PPtP, und viel stabiler und sicherer.

 

 

Jim

=======

Gemessene Download/Upload-Werte in Mbps:

Ohne VPN: 47,238 / 8,393
PPtP: 25,393/ 5,717
OpenVPN-TCP: 8,460 / 6,644
OpenVPN-UDP (MTU=default): 0,031 / 2,983     <======   nutzlos

OpenVPN-UDP (MTU=1400): 31,342 / 7,154
OpenVPN-UDP (MTU=1440): 30,462 / 7,521

 

 

Benutzerebene 3
Jupp das liegt daran, dass der Router die Pakete fragmentiert weil sie nichtmehr in ein Paket passen wenn sie größer X sind. Deshalb schafft auch die niedriegere MTU abhilfe.

Hmm, habe ich da zu früh gejubelt? Obwohl die MTU-Werte gestern noch funktionierten, tun sie es heute nicht mehr. 😞 Auch niedrigere Werte (zB 1300) machen nichts mehr.

 

[O mann, wie doof kann ein Router(firmware) denn sein? 😞 ]