Frage

O2 blockiert SIP-Registrierung / VoIP via FRITZ!Box


Kompletten Beitrag anzeigen

106 Antworten

Benutzerebene 1
Sorry @o2_Emanuel habe zu schnell hinzufügen gedrückt.

"Wir" waren so weit das O2 via Deep Packet Inspection den VPN Knackt und auch hier den SIP Port blockiert.

Ich glaube irgendwo hier @ schlu ej am 13.05.2018 19:44...

Benutzerebene 7
Zur Info

Ich nutze meine Nummern ja per Groundwire auf dem iphone und ipad. 

Sipgate Team

Aber sobald ich WLAN ausschalte, registriert sich der Client weder im LTE noch 3G, 2G Bereich.

Kann natürlich mit der Großstörung zu tun haben, die gerade bei o2 Deutschlandweit für Ausfälle sorgt.

2018-05-15T16:30:27.500Z (152xxxxxxxxxx502)
Sip::Registration::onTransportError
Correlation Id: SiphoneUserAgent[1088F0C00]SipUserAgent[1088F1C00]
State: Error
Retry: No
Error: SIP(2): Transport Dead Channel
In ali_net_sip_layer_transport_channel.cpp:734

getCurrentState: return state:Error
REGSTATECHANGED, current=Error
scheduling reconnect with timeout of 4000ms
getCurrentRealState: return state:Error
getCurrentState: return state:Error

Hallo zusammen,

 

sorry, wenn ich mich trotz der vielfach angebotenen Hilfe und insbesondere der betreffend das beschriebene Phänomen gestellten Nachfragen erst heute wieder melde. Aber ich wollte erst einmal selbst weitere „Versuche“ durchführen, bevor ich dann wieder – wofür ich sicher zurecht kritisiert wurde – irgendwelche „Verdächtigungen“ zu sehr ins Blaue hinein von mir gebe.

 

An der Zusicherung von o2_Emanuel möchte ich daher auch gar nicht zweifeln, dass VoIP-Dienste in gleich welcher Konstellation netzseitig nicht grundsätzlich blockiert werden. Nichtsdestotrotz ließ sich der Fehler zwischenzeitlich sehr zuverlässig auf eine einzige Konstellation eingrenzen; um den Fehler allerdings ursächlich zu reproduzieren, fehlen mir leider bei weitem die technischen Kenntnisse (und Möglichkeiten).

 

Geräteunabhängig tritt der Fehler weiterhin ausnahmslos im 4G-/LTE-Netz von O2 auf. Ändert man allerdings innerhalb des O2-Netzes den Netzmodus in den Geräteeinstellungen von „LTE/WCDMA/GSM (automatisch verbinden)“ auf  „WCDMA/GSM (automatisch verbinden)“, wird die heimische FRITZ!Box als SIP-Server sowohl über den nativen Android-SIP-Client als auch die App Zoiper sofort registriert. Verursacht wird der Fehler also offensichtlich (nur) durch das bzw. im LTE-Netz von O2.

 

Vielleicht ist es vor diesem Hintergrund doch ein Fall für die Technik, zumal noch bis vor kurzem auch im O2-LTE-Netz eine Registrierung der FRITZ!Box als SIP-Server möglich war. Ich bin jedenfalls nach wie vor für jede konstruktive Rückmeldung dankbar.

Benutzerebene 7
Bei mir registriert sich auch heute mein Sip Client nicht im mobilen Netz. Da ist es egal, ob 3g, LTE oder 2G.

Da es die letzten Jahre wunderbar funktioniert hat, gehe ich weiterhin von einer Netzstörung aus. Leider kann ich den Fehler nicht mit der App melden, weil da seit Januar ein Mast Problem zu lesen ist und es daher keinen Button 

anderer Meinung?

gibt. Werde morgen mal die Heisse Linie anrufen.

Hi @o3phone,

Geräteunabhängig tritt der Fehler weiterhin ausnahmslos im 4G-/LTE-Netz von O2 auf. Ändert man allerdings innerhalb des O2-Netzes den Netzmodus in den Geräteeinstellungen von „LTE/WCDMA/GSM (automatisch verbinden)“ auf  „WCDMA/GSM (automatisch verbinden)“, wird die heimische FRITZ!Box als SIP-Server sowohl über den nativen Android-SIP-Client als auch die App Zoiper sofort registriert. Verursacht wird der Fehler also offensichtlich (nur) durch das bzw. im LTE-Netz von O2.

Danke für's Testen und die Infos.

Hattest du versucht bei LTE die Verbindung ohne mVoLTE mal herzustellen?

Grüße,

Emanuel

https:///external-link.jspa?url=http%3A%2F%2Fg.o2.de%2Fcommunityeinstieg | werde https:///external-link.jspa?url=http%3A%2F%2Fg.o2.de%2Ftestprogrammund teile deine Erfahrung mit uns in https:///external-link.jspa?url=http%3A%2F%2Fg.o2.de%2Fangetestet | https:///external-link.jspa?url=http%3A%2F%2Fg.o2.de%2Ffree

Hallo zusammen, ich kann das Problem von o2phone bestätigen. Im O2 LTE Netz funktioniert SIP nicht. Per Telekom, Vodafone oder WLAN als auch per O2 3G funktioniert es einwandfrei. Das O2 LTE Netz lässt SIP nicht zu! Es wäre toll wenn das von O2 kontrolliert wird.

Benutzerebene 7
Hallo allerseits,

ich habe dies einmal intern angesfragt. Wenn es eine Antwort gibt, die wir kommunizieren können, dann melden wir uns hier im Thread noch einmal dazu. Und auch, wenn es keine Antwort gibt und wenn das ganze als Fehler aufgenommen wurde, und, und, und...

Gruß,

Lars

... manchmal kann es ganz schnell gehen ☺

Es ist dazu erst einmal so direkt nichts bekannt, @o2_Emanuel wird hier mal einige Daten sammeln und dann mal schauen, was wir heraus bekommen ☺

Gruß,

Lars

Es gehört eindeutig in den Mobilfunkbereich, da das Trägermedium eben LTE/UMTS ist und wir im DSL-Bereich nur das Transportmedium DSL mit dem Zubehör betrachten.

Abgesehen davon ist die Diskussion abstrus, da ohne Beweis behauptet wird selbst im VPN würde VoIP selektiv (!!!) blockiert, was selbst mit DPI nicht geht. Eher bekommt Merkel Fünflinge als das im VPN so was klappt.

Da das Problem nur bei O2-LTE auftaucht ist es also in dem Bereich zu klären.

Benutzerebene 7
Ich habe das Problem ja mit all meinen SIP Nummern im mobilen Netz. Einzig im VPN funktioniert es einwandfrei oder halt im WLAN. Geht weder im 2G, noch 3G noch LTE ohne VPN. 

Gleiches Problem bei mir:

Über Wlan klappt die Verbindung vom iPhone zu Sipgate sowohl mit der Zoiper, als auch der Lingphone App problemlos.

Sobald ich ins Mobilnetz wechsel scheitert es bereits an der Registrierung (getestet mit LTE und 3G).

Wie lange wird es dauern, bis das Problem behoben wird? Ihr Beitrag ist ja schon einen Monat alt.

Wenn es an gepoolten IP´s liegt vermutlich NIE!

Im heimischen WLAN und auch über VPN hat man eine eindeutige IP, die eine Kommunikation mit dem SIP-Server erlaubt. Das könnte bei Mobilfunk nicht der Fall sein. Schaut Euch doch einfach mal die IP-Range an und ob das Handy anpingbar ist.

Benutzerebene 7
Installiere einen VPN bis o2 den Fehler gefunden hat

Benutzerebene 7
Meinst Du o2 hat das geändert und dadurch den Großausfall vor ein paar Wochen verursacht? Seit dem geht es nämlich nicht mehr.

Keine Ahnung was da verstellt wurde. Könnte auch mit VoLTE o.a. Dingen zusammenhängen. Vielleicht auch nur eine geänderte Sicherheitseinstellung zum Schutz der Endgeräte.

Ich habe mit dem Sipgate Team gesprochen. Das Problem tritt anscheinend nur bei O2 Kunden sowie bei bestimmten Telekom Tarifen auf.

Ich habe bereits vor ein paar Monaten das iPhone mit meiner Fritzbox als VPN Server verbunden.

Abgesehen von der schlechteren Performance kommt es leider zu regelmäßigen Verbindungsabbrüchen, was aber wohl dem iPhone geschuldet ist, das eine VPN Verbindung nicht so lange aufrecht halten kann.

Sipgate bietet selbst einen VPN Zugang, die Verbindung besteht aber nur so lange wie sie genutzt wird und maximal 60 Minuten. Für ausgehende Anrufe mag das ja OK sein, aber eingehend....

Benutzerebene 7
VPN mit der fritzbox ist ja eher eine frickellösung die auf dem dsl aufsetzt.

ich nutze VPN von Avira und bin den ganzen Tag im VPN und habe lt. Speediest auch keine Verluste, komme auf vollen LTE Speed, wie mit ohne VPN. 

Hallo zusammen,

auch bei mir funktioniert die SIP-Verbindung zu Sipgate seit einiger Zeit nicht mehr mobil über das O2-Netz.

An der App (CSipSimple) wurde nichts geändert, zwischenzeitlich wurde die App geupdatet aber das Problem trat schon vorher auf. Über WLAN oder mobil im OpenVPN-Tunnel funktioniert alles einwandfrei.

Die Funktion VoLTE habe ich testweise deaktiviert = keine Besserung.
Daten-Roaming habe ich deaktiviert = keine Besserung (hatte ich aktiv wegen des Roamings mit Eplus damals)

Den Netzmodus umzustellen hat auch keinen Einfluss auf den Verbindungsaufbau, ebenso ein neuanlegen der Zugangspunkte, getestet im UMTS sowie LTE Netz.

Ich habe folgende Hardware (Software)

- Samsung Galaxy S7  (SM-G930F) [Android 8.0.0] [Kernel 3.18.14]

- CSipSimple [Version 1.02.03]

- 2 verschiedene Sipgate Accounts

VG

Florian

Benutzerebene 7
O2 hat ein Netzproblem, liegt nicht an dir oder irgendwelchen Einstellungen auf dem Handy. 

Ist das immer noch aktuell?

Telefonica bewirbt mit einem Produkt der Marke Ortel sogar VoIP über LTE.  Daher wäre es merkwürdig, wenn es eine Sperre oder Problem gibt. Von Netzneutralität ganz zu schweigen ...  😉

Benutzerebene 7
Ja, funktioniert weiterhin nicht. Auf die angeforderten Mails kam nie eine Antwort. 

Ich denke mal, die wissen bis heute nicht, warum es nicht funktioniert. Eine Sperre denke ich nicht, da es mir erst seit der Großstörung aufgefallen ist. Die werden da massiv etwas korrigiert haben und so das Netz wieder ans laufen gebracht, aber halt VOIP versehentlich kaputt gemacht.

Am Wochenende hatte es ab Freitagabend kurzzeitig funktioniert, habe es Samstags nochmal getestet, lief.

Sonntags war ich komplett offline, also habe mein Telefon nicht genutzt, heute (Montag) geht wieder kein VoIP, mittels VPN schon.

Dies ist aber auch nicht das einzige Problem bei O2. Werde den Vertrag wohl auslaufen lassen.

Na hoffentlich gibt es da keinen Ärger mit der BNetzA wegen der Einschränkungen. Könnte auch als Verletzung der Netzneutralität gewertet werden. Aber wenn man VoIP over LTE sogar bewirbt, dann ist da  was faul und kaum Absicht.

Benutzerebene 7
 Ich hoffe dass es Ärger gibt, vielleicht motiviert das o2 o endlich mal den Fehler zu fixen. 

Benutzerebene 3
Wo kann ich mich beschweren? Ist da die Bundesnetzagentur zuständig? Je mehr Druck ausüben und sich beschweren je schneller wird es hoffentlich gefixt.?

Hallo zusammen,

ich habe das gleiche Problem.

Keine Registrierung bei sipgate über O2/Blau.de-Netz möglich.

Folgendes habe ausprobiert:

Motorola Handy mit t-mobile Sim und linphone: läuft!

Motorola Handy mit blau.de Sim und linphone: läuft nicht!

Motorola Handy mit o2 Sim (vom o2-Homespot) und linphone: läuft nicht!

Umi-Handy mit t-mobile Sim und linphone: läuft!

Umi-Handy mit blau.de Sim und linphone: läuft nicht!

Umi-Handy mit o2 Sim (vom Homespot) und linphone: läuft nicht


o2-Homespot Huawei B525 mit t-mobile Sim: läuft!

o2-Homespot Huawei B525 mit o2 Sim: läuft nicht!

mein bisheriges WLAN über Speedport LTE 2 (telekom-Sim): läuft!

SIP-ALG aktivieren/deaktivieren brachte keine Veränderungen.

Ich bin im Juli von der Telekom weg zu o2 gewechselt, da ich hier einfach einen besseren LTE- Empfang und wesentlich mehr Datenvolumen bekomme. Telefonie sei kein Problem, VoIP ist super...

Tja, auch bei Sipgate ist man ratlos.

Es ist sehr ärgerlich, dass ich nun meine teuer portierte Festnetznummer nicht nutzen kann.

Internet läuft super, nur das PROBLEM mit VoIP ist sehr ärgelich.

Gibt es eine Lösung, das Problem zu umgehen?

Hardware: o2-Homespot (Huawei B525s-23a), analoges Telefon.

Ich habe nicht vor, mir noch irgendwelche Hardware für teuer Geld kauf zu müssen; dann hätte ich ja gleich bei den pinken bleiben und einen höheren Monatsbeitrag zahlen können.

LG Andreas

Deine Antwort