Gelöst

Samsung Galaxy S7 seit o2 Nougat Update kein Automatischer wechsel von 2G zu 3G trotz Verfügbarkeit!


Benutzerebene 3
Hallo,

wie der Titel schon sagt wechselt das Galaxy S7 seit dem Update auf Android Nougat (offiziell von o2 - Samsung) nicht mehr automatisch vom 2G ins 3G Netz - trotz guter Verfügbarkeit und Standortänderung (Luftlinie etwa 30km). Werksreset hat nichts geholfen dazu unten aber mehr..

Wähle ich in den Einstellungen unter Verbindungen "nur 3G" bleibt es problemlos im 3G Netz, ist kein 3G Verfügbar hat es natürlich kein Netz wechselt dann aber bei Verfügbarkeit direkt wieder ins o2 3G Netz.

Habe ich den Netzmodus auf LTE/3G/2G oder 3G/2G tritt das oben genannte Problem auf.

Starte ich das Handy neu verbindet er sich direkt mit dem 3G Netz.

Auch wenn ich ein paar Sekunden in den Offline-Modus wechsele und diesen Dann wieder ausschalte wechselt er direkt ins 3G Netz.

Stelle ich den Netzmodus auf "Nur 3G" wechselt er auch sofort ins 3G Netz und bleibt dort auch selbst wenn cih den Netzmodus wieder auf 3G/2G oder LTE/3G/2G stelle. Erst wenn das 3G Signal abreißt wechselt er auf 2G und dann aber trotz voller 3G Signalstärke nicht zurück.

Über die App Cell ID konnte ich sehen das wenn das Galaxy S7 im 2G Netz klemmt er (während der fahrt) munter die Mobilfunksender wechselt auf zwischen der Netzkennung 262-03 und 262-07 wechselt er problemlos hin und her. Aber an keiner Stelle von alleine - Automatisch ins 3G Netz.

Natürlich ist während der gesamten Zeit keine Telefonieverbindung aktiv welche solch einen Netztechnologiewechsel vielleicht verhindern könnte.

Da alle Tests keine Besserung brachten habe ich mir testweise das letzte Marshmellow (Android 6.0.1) Update von o2 auf das Gerät aufgespielt (Odin). 
Damit ist das Problem gelöst!

Also noch mal testweise das Update auf die Nougat Firmware von o2-de gemacht.

Das Problem war direkt wieder da!

Dann habe die Nougat Software auf dem Gerät gelassen und NUR die Modemdatei (CP) von der Android 6.0.1 Marshmellow Firmware von o2 geflasht.

Das Handy funktioniert weiterhin ohne Probleme UND das oben genannte Problem tritt NICHT auf!

Ein Test mit anderen Modemdateien der Android 7 Nougat Firmware und der Android 6.0.1 Marshmellow Firmware für das Galaxy S7 bestätigten das Ergebnis.

Mit allen Nougat Modems (die CP-Datei bis akt. DQB3) tritt das oben genannte Problem auf das das Galaxy S7 mit o2 SIM im 2G Netz hängen bleibt trotz hervorragender 3G Signalstärke.

Mit allen Marshellow Modems (die CP-Datei bsp. BPJG) tritt das oben genannte Problem nicht auf. ist 3G mit akzeptabler Signalstärke vorhanden wird problemlos in dieses Netz gewechselt.

Mangels SIM-Karte eines anderen Netzes konnte ich es leider nicht testen ob dies in anderen - Deutschen - Mobilfunknetzen auch der Fall ist. 

Aber es scheint das es mit den Modemdateien der Android 7 Firmware für das Galaxy S7 eine Inkombatibilität mit dem Netz von o2/ePlus gibt.

Ich hoffe das meine ganzen Tests und versuche und die Zeit die ich dafür und in das schreiben dieses Beitrages investiert habe nicht umsonst waren und dieser Beitrag einen zuständigen Sachbearbeiter bei o2 in der Techik erreicht welche dieses Verhalten zu 99% reproduzieren können werden und hoffentlich dafür eine Lösung finden für die Kunden die Technisch deutlich weniger versiert sind und einfach ihr Galaxy S7 im 3G Netz (bei Verfügbarkeit) problemlos nutzen wollen ohne im 2G Netz hängen zu bleiben.

icon

Lösung von o2_Marc 2 März 2017, 14:05

Hi maik0055,



 



vorab Danke für die Mühe.



 



Nun stellt sich allerdings die Frage, ob dieses Problem vereinzelt auftritt oder mehrere Nutzer betrifft.



 



Da dein Smartphone anscheinend geflasht ist, wird eine Fehleranalyse für mich schwierig sein. Ob diese Einschränkung möglicherweise daraus resultiert, lässt sich sicher nicht ganz abstreiten.



Sollten ähnliche Einschränkungen auch mit dem S7 Geräten bestehen, welche noch die Original-Software besitzen, wird dies sicher hier kommentiert.



 



Gruß,



Marc



Zur Antwort springen

127 Antworten

Benutzerebene 7
Abzeichen +2
Was hat das mit dir zu tun? Wenn o2 ein Update fertig hat, wird es ausgerollt, ob jemand danach fragt oder nicht.

Benutzerebene 7
Abzeichen +2
Kopiere doch deinen Beitrag und erstelle einen Blog. Das macht mehr sinn, denn dieser Beitrag ist in ein paar Wochen eh unsichtbar, der Blog nicht.

Ich habe das Selbe Problem bei meinem S7 ! Das Update hat das Handy von alleine gemacht nach dem ich das W-Lan eingeschaltet habe das Handy ist ein freies was ich letztes Jahre noch von Base bekommen habe Samsung sagte gestern zu mir am Telefon ich sollte mich an O2 wenden das wäre ein Netz Fehler und würde an der Sim karte liegen wo ich dann sagte mit Android 6 gab es keine Probleme jetzt mit Android 7 habe ich sie das kann doch nicht sein dann sagte mal mir ich soll bei O2 anrufen und hat dann den Hörer aufgelegt tolle Sache

Benutzerebene 7
Abzeichen +2
Dir hilft nur aussitzen, bis o2 mal ein Update rausbringt, oder den manuellen Downgrade auf Android 6.

Hallo. Habe nach langen Suchen folgenden Vorschlag im Netz gefunden. 

Handy ausschalten
Sim Card entnehmen
kurze Zeit warten
Sim Card wieder reinpacken
Reboot

So erkennt das Handy einen Sim Karten wechsel und das Sim Card Register ist aktualisiert.

Bei meinem S7 hat das geholfen und der Zustand hat sich wesentlich gebessert, obwohl der Wechsel von 2G zu 3G  immer noch schlechter ist als bei Marshmallow. 

Benutzerebene 3
Hatte ich bei meinem S7 bereits mehrmals versucht SIM Karte entnehmen und wieder einlegen bei eingeschaltetem und bei ausgeschaltetem Gerät. Geändert hat das nichts.

Habe bei meinem S7 Edge das gleiche Problem und muss seit dem Update immer einmal kurz den Flugmodus einschalten damit dann in bessere Netz gewechselt wird.

Habe vor 2 Monaten von iPhone zum S7 gewechselt und kann nur sagen das es ein Riesen Fehler war. So viele Probleme hatte ich noch nie mit einem Smartphone.

hallo,  auch bei meinem s7 edge das gleiche,  was mich etwas wundert,  das selbe problem gab es schon letztes jahr als das s7/s7 edge rauskam mit android 6 und wurde dann nochmals mit einem update behoben.  ich hoffe das das ganze ziemlich schnell behoben wird,  ist doch ziemlich nervig. ...

Benutzerebene 2
Hallo.habt ihr denn schon mal versucht wie es ist wenn ihr das Daten Roaming mal abschaltet? Bei uns hats funktioniert und ich kann das nur empfehlen mal zu versuchen.

Hallo, ich habe auch das gleiche Problem das sich mein Handy nur bei LTE Netz verbindet und sonst gar kein Internet vorhanden ist. 

Viele Grüße 

Benutzerebene 3
Das Problem letztes Jahr beim Verkaufsstart war ein anderes. Dort hat das S7 oft angezeigt das es nicht im Netzwerk registriert ist. Telefonie/SMS/Daten waren dann nicht möglich obwohl eingentlich ein guter Netzempfang möglich wäre. Dies wurde dann ja auch durch ein Update behoben.

Aber das "diesjährige" Problem ist ein anderes.

Benutzerebene 3
Daten Roaming ist bei mir permanent aus. 

Hatte es auch testweise mal eingeschaltet aber ohne Unterschied.

@o2_Kurt

Das Problem muss bitte dringend von euch an Samsung gemeldet werden. Das Problem werden alle Kunden von o2 mit dem neuen Android 7 Update von Samsung für das S7 & S7 Edge haben. Wahrscheinlich ist es vielen auch noch gar nicht aufgefallen. 

Auch ich bin mit einem brandingfreien Gerät (DBT) betroffen. Es ist eindeutig ein Problem mit dem Android 7 Modem. Unter Android 6 funktioniert alles einwandfrei. Auch diverse Werksresets haben nichts gebracht. 

Wenn ein Smartphone eine Updatemeldung für eine neue Version erhält, dann wird auch hier die Firmware geflasht ... 

Was du vielleicht wissen möchtest ist, ob ein Kunde ein Custom ROM installiert hat.

An die restlichen Kunden, wendet euch bitte direkt an den Samsung Support und macht Samsung auf das Problem aufmerksam. Erst wenn sich viele Kunden melden, wird Samsung diesem Problem eine gewisse Priorität zuordnen. Da es bei Beta-Testern schon zu diesem Problem gekommen ist und Samsung es nicht behoben hat, können wir noch lange auf eine Fehlerbehebung warten. Deswegen bitte ich euch direkt an Samsung zu wenden. 

Benutzerebene 3
Heute wurde eine neue Firmware veröffentlicht
G930FXXU1DQCG
EVR CSC.

Habe nun das Modem daraus geflasht.

CP_G930FXXU1DQCG_CL10422490_QB12903596_REV00_user_low_ship.tar

Werde heute Abend berichten.
Der Dateiname ist wieder normal. Auch die Versionsnummern. Firmware düfte etwa vom 17.3.2017 sein.

Vielen Dank für deine Antwort. Über eine Rückmeldung wäre ich dankbar. Ich hoffe das es mit dem neuen Modem besser läuft, jedoch denke ich nicht das Samsung es gefixt haben wird. 

Wenn es doch was gebracht haben sollte, dann halte ich mal für das S7 Edge ausschau nach einer neuen Firmware und Modem.

Benutzerebene 3
Das QC2 Modem hat ja immerhin auch wieder von 2G auf 3G gewechselt.. allerdings nicht immer und wenn dann mit sehr sehr großer Verzögerung. So etwa 10-x Minuten statt wie unter Marshmallow innerhalb weniger Sekunden.

Also ich habe mir die App 4G Switcher unter geladen und die ist echt gut seitdem habe ich keine Probleme mehr mit dem wechsel von 2G auf 3G

Benutzerebene 3
Und was machst du mit der App bzw. wie verwendest du die?

Hi sorry das ich mich jetzt erst melde habe die App einfach Installiert danach habe ich das s7 für ein paar Sekunden in den Offline Modus gestellt Offline Modus wieder aus und es läuft ohne Probleme bei meinem s7 die App steht auf Auto lass alles so stehen wie es ist bei mir läuft die App super

Selbes Problem bei mir, gibt es mittlerweile eine Lösung? Hab auch keine geflashte FW alles original.. Nervt halt nur immer in den Flugmodus zu wechseln. Ist doch nicht normal bei so einem Teuren Handy.. 

Scheine die Lösung gefunden zuhaben:

Hatte vor drei Tagen das Problem mit LTE auf meinem Galaxy S7 Edge. Keine Anrufe kamen bei mir an, doch ich konnte ausgehende Gespräche führen.

Beste Lösung war: "VoLTE- Anrufe" ausschalten - siehe Bild:

Einstellung >>> Verbindungen >>> Mobile Netzwerke >>> VoLTE-Anrufe schalter aus



Ich hoffe, einigen damit geholfen zuhaben.#

Leider ist diese Option bei mir dauerhaft schon ausgeschaltet brachte leider keine Besserung 

Ich vergass zu erwähnen, das ich vorher ein Zurücksetzen auf Standartwerte gemacht hatte beim Galaxy S7 ist das:

Einstellung >>> Allgemeine Verwaltung >>> Zurücksetzen >>> Einstellungen zurücksetzen



Leider immer noch keine Besserung, ich hoffe da wird bald nachgebessert durch ein Update so macht das keinen Sinn und Spaß.. 

Falls es jemanden interessiert habe gestern das Modem aus Android 6 geflasht also alles original und jetzt läuft es fast überall nur 4G bzw Lte Empfang.. Ich weiß nicht warum es so schwer ist für 02 sich mal dahinter zu klemmen.. 

Deine Antwort